package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d+Mbps/(\d+)M`)
var str = `My ADSL 14Mbps/2M speed
My ADSL 2M(200) Volume 14Mbps/2M speed threshold 0M`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}