// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d+Mbps/(\d+)M").unwrap();
let string = "My ADSL 14Mbps/2M speed
My ADSL 2M(200) Volume 14Mbps/2M speed threshold 0M";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}