const regex = new RegExp('\\d+Mbps/(\\d+)M', 'gm')
const str = `My ADSL 14Mbps/2M speed
My ADSL 2M(200) Volume 14Mbps/2M speed threshold 0M`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}