$re = '@\d+Mbps/(\d+)M@m';
$str = 'My ADSL 14Mbps/2M speed
My ADSL 2M(200) Volume 14Mbps/2M speed threshold 0M';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);