using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(([A-Z][a-z]+)(?=[\ ])|([A-Z][a-z]*[\'\-])(?=[A-Z]?[a-z]+)|([A-Z][a-z]+)(?![\ '\-])|(?<=[\'\-])([a-z]+)|(?<=[a-z])([\ ])(?=[A-Z]))+$";
string input = @"Kamal Manil
Kamal O'Neil
Kamal Manil Malaka
Kamal Al-Shaba
Al-shaba
O'neil
Ol'Neil
Jo Jo
Jo
Kamal Manil
Kamal O' Neil
Kamal Manil Malaka
Kamal Al- Shaba
Al -shaba
O 'neil
Jo Jo
A B C Jo
Kamal SDF -''''sdf''-
A
a
A B
-Shana
'Neil
-shaba
'neil
([A-Z][a-z]+(?![\'\-]))";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}