import re
regex = re.compile(r"^(([A-Z][a-z]+)(?=[\ ])|([A-Z][a-z]*[\'\-])(?=[A-Z]?[a-z]+)|([A-Z][a-z]+)(?![\ '\-])|(?<=[\'\-])([a-z]+)|(?<=[a-z])([\ ])(?=[A-Z]))+$", flags=re.MULTILINE | re.DOTALL)
test_str = ("Kamal Manil\n"
"Kamal O'Neil\n"
"Kamal Manil Malaka\n"
"Kamal Al-Shaba\n"
"Al-shaba\n"
"O'neil\n"
"Ol'Neil\n"
"Jo Jo\n"
"Jo\n\n"
" Kamal Manil\n"
"Kamal O' Neil\n"
"Kamal Manil Malaka \n"
"Kamal Al- Shaba\n"
"Al -shaba\n"
"O 'neil\n"
"Jo Jo\n"
"A B C Jo\n"
"Kamal SDF -''''sdf''- \n"
" \n"
"A\n"
"a\n"
"A B\n"
"-Shana\n"
"'Neil\n"
"-shaba\n"
"'neil\n\n\n"
"([A-Z][a-z]+(?![\\'\\-]))")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")