import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([A-Z][a-z]+)(?=[\\ ])|([A-Z][a-z]*[\\'\\-])(?=[A-Z]?[a-z]+)|([A-Z][a-z]+)(?![\\ '\\-])|(?<=[\\'\\-])([a-z]+)|(?<=[a-z])([\\ ])(?=[A-Z]))+$";
final String string = "Kamal Manil\n"
+ "Kamal O'Neil\n"
+ "Kamal Manil Malaka\n"
+ "Kamal Al-Shaba\n"
+ "Al-shaba\n"
+ "O'neil\n"
+ "Ol'Neil\n"
+ "Jo Jo\n"
+ "Jo\n\n"
+ " Kamal Manil\n"
+ "Kamal O' Neil\n"
+ "Kamal Manil Malaka \n"
+ "Kamal Al- Shaba\n"
+ "Al -shaba\n"
+ "O 'neil\n"
+ "Jo Jo\n"
+ "A B C Jo\n"
+ "Kamal SDF -''''sdf''- \n"
+ " \n"
+ "A\n"
+ "a\n"
+ "A B\n"
+ "-Shana\n"
+ "'Neil\n"
+ "-shaba\n"
+ "'neil\n\n\n"
+ "([A-Z][a-z]+(?![\\'\\-]))";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}