const regex = /^(([A-Z][a-z]+)(?=[\ ])|([A-Z][a-z]*[\'\-])(?=[A-Z]?[a-z]+)|([A-Z][a-z]+)(?![\ '\-])|(?<=[\'\-])([a-z]+)|(?<=[a-z])([\ ])(?=[A-Z]))+$/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(([A-Z][a-z]+)(?=[\\ ])|([A-Z][a-z]*[\\\'\\-])(?=[A-Z]?[a-z]+)|([A-Z][a-z]+)(?![\\ \'\\-])|(?<=[\\\'\\-])([a-z]+)|(?<=[a-z])([\\ ])(?=[A-Z]))+$', 'gms')
const str = `Kamal Manil
Kamal O'Neil
Kamal Manil Malaka
Kamal Al-Shaba
Al-shaba
O'neil
Ol'Neil
Jo Jo
Jo
Kamal Manil
Kamal O' Neil
Kamal Manil Malaka
Kamal Al- Shaba
Al -shaba
O 'neil
Jo Jo
A B C Jo
Kamal SDF -''''sdf''-
A
a
A B
-Shana
'Neil
-shaba
'neil
([A-Z][a-z]+(?![\\'\\-]))`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}