import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?P<x>.*?)(?: - |(?<!\\d\\d)$))?(?P<y>.*?(?:,|(?<!\\d\\d)$))?(?:\\s*(?P<z>\\d{2}))?$";
final String string = "a\n"
+ "a - b\n"
+ "a - b-c\n"
+ "a - b, 12\n"
+ "a - 12\n"
+ "12";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}