$re = '/^(?:(?P<x>.*?)(?: - |(?<!\d\d)$))?(?P<y>.*?(?:,|(?<!\d\d)$))?(?:\s*(?P<z>\d{2}))?$/m';
$str = 'a
a - b
a - b-c
a - b, 12
a - 12
12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);