const regex = new RegExp('^(?:(?P<x>.*?)(?: - |(?<!\\d\\d)$))?(?P<y>.*?(?:,|(?<!\\d\\d)$))?(?:\\s*(?P<z>\\d{2}))?$', 'gm')
const str = `a
a - b
a - b-c
a - b, 12
a - 12
12`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}