re = /^(?:(?P<x>.*?)(?: - |(?<!\d\d)$))?(?P<y>.*?(?:,|(?<!\d\d)$))?(?:\s*(?P<z>\d{2}))?$/m
str = 'a
a - b
a - b-c
a - b, 12
a - 12
12'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end