import re
regex = re.compile(r"^(?:(?P<x>.*?)(?: - |(?<!\d\d)$))?(?P<y>.*?(?:,|(?<!\d\d)$))?(?:\s*(?P<z>\d{2}))?$", flags=re.MULTILINE)
test_str = ("a\n"
"a - b\n"
"a - b-c\n"
"a - b, 12\n"
"a - 12\n"
"12")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")