package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:00|\+)[0-9]+(?:\s*[0-9]+)+$`)
var str = `+14917672662642
+14917 67 266 264 2
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}