$re = '/^(?:00|\+)[0-9]+(?:\s*[0-9]+)+$/m';
$str = '+14917672662642
+14917 67 266 264 2
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);