const regex = /^(?:00|\+)[0-9]+(?:\s*[0-9]+)+$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:00|\\+)[0-9]+(?:\\s*[0-9]+)+$', 'mg')
const str = `+14917672662642
+14917 67 266 264 2
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}