import re
regex = re.compile(r"^(?:00|\+)[0-9]+(?:\s*[0-9]+)+$", flags=re.MULTILINE)
test_str = ("+14917672662642\n"
"+14917 67 266 264 2\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")