re = /^(?:00|\+)[0-9]+(?:\s*[0-9]+)+$/m
str = '+14917672662642
+14917 67 266 264 2
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end