# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(https?:\\/\\/)[\w.-]+(?<!\.domain\.edu)$/\1my.domain.edu/gm;t' <<< "https://www.google.com
http://not.the.best.example.org
http://another.bad.example.erewhon.edu
https://my.domain.com
https://your.page.domain.edu
http://good.domain.edu"