const regex = /^(https?:\/\/)[\w.-]+(?<!\.domain\.edu)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(https?:\\\/\\\/)[\\w.-]+(?<!\\.domain\\.edu)$', 'gm')
const str = `https://www.google.com
http://not.the.best.example.org
http://another.bad.example.erewhon.edu
https://my.domain.com
https://your.page.domain.edu
http://good.domain.edu`;
const subst = `\1my.domain.edu`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);