import re
regex = re.compile(r"^(https?:\/\/)[\w.-]+(?<!\.domain\.edu)$", flags=re.MULTILINE)
test_str = ("https://www.google.com\n"
"http://not.the.best.example.org\n"
"http://another.bad.example.erewhon.edu\n"
"https://my.domain.com\n"
"https://your.page.domain.edu\n"
"http://good.domain.edu")
subst = "\\1my.domain.edu"
result = regex.sub(subst, test_str)
if result:
print(result)