import Foundation
let pattern = #"^(https?:\/\/)[\w.-]+(?<!\.domain\.edu)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://www.google.com
http://not.the.best.example.org
http://another.bad.example.erewhon.edu
https://my.domain.com
https://your.page.domain.edu
http://good.domain.edu
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1my.domain.edu"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)