import re
regex = re.compile(r"ng-click=\"vm\.onClickTab\((.*?)'\)")
test_str = " ng-click=\"vm.onClickTab('wanted')\""
subst = "ng-click=\"vm\\.onClickTab\\($1', $event\\)"
result = regex.sub(subst, test_str)
if result:
print(result)