re = /ng-click="vm\.onClickTab\((.*?)'\)/
str = ' ng-click="vm.onClickTab(\'wanted\')"'
subst = 'ng-click="vm\\.onClickTab\\($1\', $event\\)'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result