#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?:(?:[A-Z'-]{2,}[ ]){1,})((?:[ ]?[A-Z][a-z\u00E0-\u0178'-]+){1,})|((?:[A-Z][a-z\u00E0-\u0178'-]+[ ]){1,})([A-Z'-]{2,}))$"
Local $sString = "Jean Jacque HUGES" & @CRLF & _
"LE CROIX Jean Pierre" & @CRLF & _
"Marcel M'FILLET" & @CRLF & _
"Hèrbère DUHARV" & @CRLF & _
"Duval Monica Del Rio BENNETT" & @CRLF & _
"SAMUEL ADEBE BAYOR Tristan" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")