import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?:(?:[A-Z'-]{2,}[ ]){1,})((?:[ ]?[A-Z][a-z\\u00E0-\\u0178'-]+){1,})|((?:[A-Z][a-z\\u00E0-\\u0178'-]+[ ]){1,})([A-Z'-]{2,}))$";
final String string = "Jean Jacque HUGES\n"
+ "LE CROIX Jean Pierre\n"
+ "Marcel M'FILLET\n"
+ "Hèrbère DUHARV\n"
+ "Duval Monica Del Rio BENNETT\n"
+ "SAMUEL ADEBE BAYOR Tristan\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}