use strict;
my $str = 'Jean Jacque HUGES
LE CROIX Jean Pierre
Marcel M\'FILLET
Hèrbère DUHARV
Duval Monica Del Rio BENNETT
SAMUEL ADEBE BAYOR Tristan
';
my $regex = qr/^((?:(?:[A-Z'-]{2,}[ ]){1,})((?:[ ]?[A-Z][a-z\u00E0-\u0178'-]+){1,})|((?:[A-Z][a-z\u00E0-\u0178'-]+[ ]){1,})([A-Z'-]{2,}))$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}