const regex = /^((?:(?:[A-Z'-]{2,}[ ]){1,})((?:[ ]?[A-Z][a-z\u00E0-\u0178'-]+){1,})|((?:[A-Z][a-z\u00E0-\u0178'-]+[ ]){1,})([A-Z'-]{2,}))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?:(?:[A-Z\'-]{2,}[ ]){1,})((?:[ ]?[A-Z][a-z\\u00E0-\\u0178\'-]+){1,})|((?:[A-Z][a-z\\u00E0-\\u0178\'-]+[ ]){1,})([A-Z\'-]{2,}))$', 'gm')
const str = `Jean Jacque HUGES
LE CROIX Jean Pierre
Marcel M'FILLET
Hèrbère DUHARV
Duval Monica Del Rio BENNETT
SAMUEL ADEBE BAYOR Tristan
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}