re = /^((?:(?:[A-Z'-]{2,}[ ]){1,})((?:[ ]?[A-Z][a-z\u00E0-\u0178'-]+){1,})|((?:[A-Z][a-z\u00E0-\u0178'-]+[ ]){1,})([A-Z'-]{2,}))$/m
str = 'Jean Jacque HUGES
LE CROIX Jean Pierre
Marcel M\'FILLET
Hèrbère DUHARV
Duval Monica Del Rio BENNETT
SAMUEL ADEBE BAYOR Tristan
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end