# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\[TITLE(?:\|[^\][]*)?)]/$1|suffix=z]/gmi;t' <<< "Lorem ipsum [TITLE|prefix=a] dolor [sit] amet [consectetur] [TITLE]"