using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\[TITLE(?:\|[^\][]*)?)]";
string substitution = @"$1|suffix=z]";
string input = @"Lorem ipsum [TITLE|prefix=a] dolor [sit] amet [consectetur] [TITLE]";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}