use strict;
my $str = 'Lorem ipsum [TITLE|prefix=a] dolor [sit] amet [consectetur] [TITLE]';
my $regex = qr/(\[TITLE(?:\|[^\][]*)?)]/mip;
my $subst = '$1|suffix=z]';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";