const regex = /(\[TITLE(?:\|[^\][]*)?)]/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\[TITLE(?:\\|[^\\][]*)?)]', 'gmi')
const str = `Lorem ipsum [TITLE|prefix=a] dolor [sit] amet [consectetur] [TITLE]`;
const subst = `$1|suffix=z]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);