import re
regex = re.compile(r"(\[TITLE(?:\|[^\][]*)?)]", flags=re.MULTILINE | re.IGNORECASE)
test_str = "Lorem ipsum [TITLE|prefix=a] dolor [sit] amet [consectetur] [TITLE]"
subst = "$1|suffix=z]"
result = regex.sub(subst, test_str)
if result:
print(result)