#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\w+).*\(.*?\),[ ]*(\w+).*$"
Local $sString = "Doe (Developer), John(123456)"
Local $sSubst = "$2 $1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)