use strict;
my $str = 'Doe (Developer), John(123456)';
my $regex = qr/^(\w+).*\(.*?\),[ ]*(\w+).*$/mp;
my $subst = '$2 $1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";