$re = '/^(\w+).*\(.*?\),[ ]*(\w+).*$/m';
$str = 'Doe (Developer), John(123456)';
$subst = "$2 $1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;