// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\w+).*\(.*?\),[ ]*(\w+).*$").unwrap();
let string = "Doe (Developer), John(123456)";
let substitution = "$2 $1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}