import re
regex = re.compile(r"^(\w+).*\(.*?\),[ ]*(\w+).*$", flags=re.MULTILINE)
test_str = "Doe (Developer), John(123456)"
subst = "$2 $1"
result = regex.sub(subst, test_str)
if result:
print(result)