package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[+-]?(\d*|\d{1,3}(,\d{3})*)(\.\d+)?\b$`)
var str = `There are 1,000 people in those 3 towns.
1,000
3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}