const regex = /^[+-]?(\d*|\d{1,3}(,\d{3})*)(\.\d+)?\b$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[+-]?(\\d*|\\d{1,3}(,\\d{3})*)(\\.\\d+)?\\b$', 'gm')
const str = `There are 1,000 people in those 3 towns.
1,000
3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}