re = /^[+-]?(\d*|\d{1,3}(,\d{3})*)(\.\d+)?\b$/m
str = 'There are 1,000 people in those 3 towns.
1,000
3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end