$re = '/^[+-]?(\d*|\d{1,3}(,\d{3})*)(\.\d+)?\b$/m';
$str = 'There are 1,000 people in those 3 towns.
1,000
3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);