// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[+-]?(\d*|\d{1,3}(,\d{3})*)(\.\d+)?\b$").unwrap();
let string = "There are 1,000 people in those 3 towns.
1,000
3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}