using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*?\btwitter\.com/@?(\w+(?:\s+\w+)*)(?:[?/,].*)?$";
string input = @"https://www.twitter.com/sachin
https://www.twitter.com/@sachin
https://www.twitter.com/@sachin
https://www.twitter.com/sachin?lang=en
http://twitter.com/sachin mohan";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}