package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*?\btwitter\.com/@?(\w+(?:\s+\w+)*)(?:[?/,].*)?$`)
var str = `https://www.twitter.com/sachin
https://www.twitter.com/@sachin
https://www.twitter.com/@sachin
https://www.twitter.com/sachin?lang=en
http://twitter.com/sachin mohan`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}