$re = '/^.*?\btwitter\.com/@?(\w+(?:\s+\w+)*)(?:[?/,].*)?$/m';
$str = 'https://www.twitter.com/sachin
https://www.twitter.com/@sachin
https://www.twitter.com/@sachin
https://www.twitter.com/sachin?lang=en
http://twitter.com/sachin mohan';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);