import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*?\\btwitter\\.com/@?(\\w+(?:\\s+\\w+)*)(?:[?/,].*)?$";
final String string = "https://www.twitter.com/sachin\n"
+ "https://www.twitter.com/@sachin\n"
+ "https://www.twitter.com/@sachin\n"
+ "https://www.twitter.com/sachin?lang=en\n"
+ "http://twitter.com/sachin mohan";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}