re = /^.*?\btwitter\.com\/@?(\w+(?:\s+\w+)*)(?:[?\/,].*)?$/m
str = 'https://www.twitter.com/sachin
https://www.twitter.com/@sachin
https://www.twitter.com/@sachin
https://www.twitter.com/sachin?lang=en
http://twitter.com/sachin mohan'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end