#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.{32}$)[a-zA-Z0-9]*[^\w\n][a-zA-Z0-9]*$"
Local $sString = "123456789012345-7890123456789012" & @CRLF & _
"12345678901234567890123456789012" & @CRLF & _
"abcdefghijabcdefghijabcdefghijkl" & @CRLF & _
"abcdefghijabcdefghijabcdefghij1l" & @CRLF & _
"abcdefghijabcdefghijabcdefg\ij1l"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")